re = /^(0+\.[0-9]?e?[+-]?[0-9]+)\s+([0-9]+\.?[0-9]*|[0-9][0-9]?[0-9]?[A-Z][a-z]?)\s+([0-9][0-9]?[0-9]?)\s+(\[.*\])\s+(\[.*\])$/m
str = '0.625846 29Si 29 [4934.39 0] [0.84 100000000000000.0]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end