import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=\\.\\s)|^)[A-Z][^.A-Z]*(?:(?:[A-Z]\\.|\\.\\s\\d)[^.A-Z]*)*\\bnice one\\b.+?(?=\\s[A-Z])";
final String string = "One sentence here, much wow. Another one here. This is O.N.E. example n. 1, a nice one to understand. Hope it's clear now!\n\n"
+ "This is O.N.E. example n. 1, a nice one to understand. Hope it's clear now!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}