re = /(?:(?<=\.\s)|^)[A-Z][^.A-Z]*(?:(?:[A-Z]\.|\.\s\d)[^.A-Z]*)*\bnice one\b.+?(?=\s[A-Z])/m
str = 'One sentence here, much wow. Another one here. This is O.N.E. example n. 1, a nice one to understand. Hope it\'s clear now!
This is O.N.E. example n. 1, a nice one to understand. Hope it\'s clear now!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end