$re = '/(?:(?<=\.\s)|^)[A-Z][^.A-Z]*(?:(?:[A-Z]\.|\.\s\d)[^.A-Z]*)*\bnice one\b.+?(?=\s[A-Z])/m';
$str = 'One sentence here, much wow. Another one here. This is O.N.E. example n. 1, a nice one to understand. Hope it\'s clear now!
This is O.N.E. example n. 1, a nice one to understand. Hope it\'s clear now!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);