import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^.]*(cervi(c|x)|C[1-7]|T[1-6]).*?\\.(?=[^.]*L[1-5][^.]*\\.)";
final String string = "There is a finding on T2 of spine. The finding is most likely fracture. Additionally, patient seems tired. In L2, patient has there is a circumferential disc bulge with Central disc herniation. In L5, patient seems to have another fracture. In the cervical spine, patient has any degeneration. Patient is may also have fever. L3, endplate edema is also found. In L5, patient may have bruise.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}