re = /[^.]*(cervi(c|x)|C[1-7]|T[1-6]).*?\.(?=[^.]*L[1-5][^.]*\.)/m
str = 'There is a finding on T2 of spine. The finding is most likely fracture. Additionally, patient seems tired. In L2, patient has there is a circumferential disc bulge with Central disc herniation. In L5, patient seems to have another fracture. In the cervical spine, patient has any degeneration. Patient is may also have fever. L3, endplate edema is also found. In L5, patient may have bruise.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end