const regex = /[^.]*(cervi(c|x)|C[1-7]|T[1-6]).*?\.(?=[^.]*L[1-5][^.]*\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^.]*(cervi(c|x)|C[1-7]|T[1-6]).*?\\.(?=[^.]*L[1-5][^.]*\\.)', 'gm')
const str = `There is a finding on T2 of spine. The finding is most likely fracture. Additionally, patient seems tired. In L2, patient has there is a circumferential disc bulge with Central disc herniation. In L5, patient seems to have another fracture. In the cervical spine, patient has any degeneration. Patient is may also have fever. L3, endplate edema is also found. In L5, patient may have bruise.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}