import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h{2}\\R";
final String string = "1 \n"
+ "08.778 \n"
+ "09.870 \n"
+ "09.870 \n"
+ "11.947 \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "2 \n"
+ "09.112 \n"
+ "09.664 \n"
+ "09.681 \n"
+ "17.090";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}