const regex = new RegExp('^\\h{2}\\R', 'gm')
const str = `1
08.778
09.870
09.870
11.947
2
09.112
09.664
09.681
17.090`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);