import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+?(?=W[0-9][0-9]?)(W[0-9][0-9]?)(W[0-9][0-9]?).*$";
final String string = "asfadfW2W1adfs\n"
+ "MeanW15W14PM3TCPMatchC3CapPositionAIReading\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}