$re = '/^.+?(?=W[0-9][0-9]?)(W[0-9][0-9]?)(W[0-9][0-9]?).*$/m';
$str = 'asfadfW2W1adfs
MeanW15W14PM3TCPMatchC3CapPositionAIReading
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);