const regex = /^.+?(?=W[0-9][0-9]?)(W[0-9][0-9]?)(W[0-9][0-9]?).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+?(?=W[0-9][0-9]?)(W[0-9][0-9]?)(W[0-9][0-9]?).*$', 'gm')
const str = `asfadfW2W1adfs
MeanW15W14PM3TCPMatchC3CapPositionAIReading
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}