use strict;
my $str = 'https://www.some.fr/812?utm=6901&utm=ewe';
my $regex = qr/(?<=&|\?)utm.*?(&|$)/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";