re = /(?<=&|\?)utm.*?(&|$)/im
str = 'https://www.some.fr/812?utm=6901&utm=ewe'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result