$re = '/(?<=&|\?)utm.*?(&|$)/im';
$str = 'https://www.some.fr/812?utm=6901&utm=ewe';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;