$re = '/^[ ]+|[ ]+$/m';
$str = ' Force [N]
Stress [MPa] ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;