import re
regex = re.compile(r"^[ ]+|[ ]+$", flags=re.MULTILINE)
test_str = (" Force [N] \n"
" Stress [MPa] ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)