const regex = /\b\d{4}\K\d+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{4}\\K\\d+\\b', 'gm')
const str = `99999999
12345.66
1234
abc99999999
99999999abc`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);