$re = '/\b\d{4}\K\d+\b/m';
$str = '99999999
12345.66
1234
abc99999999
99999999abc';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;