const regex = /(\bused)(.*?\((\d*)%\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bused)(.*?\\((\\d*)%\\))', 'g')
const str = `C: - total 79.45 Gb - used: 33.82 Gb (43%) - free 45.63 Gb (57%) `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}