re = /(\bused)(.*?\((\d*)%\))/
str = 'C: - total 79.45 Gb - used: 33.82 Gb (43%) - free 45.63 Gb (57%) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end