$re = '/(\bused)(.*?\((\d*)%\))/';
$str = 'C: - total 79.45 Gb - used: 33.82 Gb (43%) - free 45.63 Gb (57%) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);