#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)1|2|3|4|5|6|7|8|9|one|two|three|four|five|six|seven|eight|nine"
Local $sString = "two1nine" & @CRLF & _
"eightwothree" & @CRLF & _
"abcone2threexyz" & @CRLF & _
"xtwone3four" & @CRLF & _
"4nineeightseven2" & @CRLF & _
"zoneight234" & @CRLF & _
"7pqrstsixteen"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")