import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "1|2|3|4|5|6|7|8|9|one|two|three|four|five|six|seven|eight|nine";
final String string = "two1nine\n"
+ "eightwothree\n"
+ "abcone2threexyz\n"
+ "xtwone3four\n"
+ "4nineeightseven2\n"
+ "zoneight234\n"
+ "7pqrstsixteen";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}