$re = '/1|2|3|4|5|6|7|8|9|one|two|three|four|five|six|seven|eight|nine/m';
$str = 'two1nine
eightwothree
abcone2threexyz
xtwone3four
4nineeightseven2
zoneight234
7pqrstsixteen';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);