using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(?:\b(and|or|not)\b|$)";
string input = @"some column name1 = some value1 and some column name2 < another value2 or some column name 3 > value3 not column name 4 = value4 and name5 = value5";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}