package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?)(?:\b(and|or|not)\b|$)`)
var str = `some column name1 = some value1 and some column name2 < another value2 or some column name 3 > value3 not column name 4 = value4 and name5 = value5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}