re = /(.*?)(?:\b(and|or|not)\b|$)/
str = 'some column name1 = some value1 and some column name2 < another value2 or some column name 3 > value3 not column name 4 = value4 and name5 = value5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end