import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<symbol>[^,]{1,8})(?:,[A-Z.]*)*\\s+-\\s+(?P<title>(?:(?!Q\\d).)*?)\\s*(?P<period>Q\\d)?\\s?(?P<year>(?:19|20)\\d{2})?$";
final String string = "AXP - Earnings call Q2 2021\n"
+ "AXP - Conference call 2021\n"
+ "BAC,BAC.PE,BAC.PL,BACRP,BML.PL,BML.PJ,BML.PH,BML.PG,BAC.PB,BAC.PK,BAC.PM,BAC.PN - Earnings call Q2 2021\n"
+ "GM - General Motors Company (GM) Presents at Deutsche Bank AutoTech Conference\n"
+ "AXP - American Express Company (AXP) Management Presents at Barclays 2020 Global Financial Services Conference";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}