#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\d+\/\d+\/\d+)\b"
Local $sString = "0 03/25/93 Total time of visit (in minutes):\n" & @CRLF & _
"1 6/18/85 Primary Care Doctor:\n" & @CRLF & _
"2 sshe plans to move as of 7/8/71 In-Home Servic..." & @CRLF & _
"3 7 on 9/27/75 Audit C Score Current:\n" & @CRLF & _
"4 2/6/96 sleep studyPain Treatment Pain Level (N..." & @CRLF & _
"5 .Per 7/06/79 Movement D/O note:\n" & @CRLF & _
"6 4, 5/18/78 Patient's thoughts about current su..." & @CRLF & _
"7 10/24/89 CPT Code: 90801 - Psychiatric Diagnos..." & @CRLF & _
"8 3/7/86 SOS-10 Total Score:\n" & @CRLF & _
"9 (4/10/71)Score-1Audit C Score Current:\n" & @CRLF & _
"10 (5/11/85) Crt-1.96, BUN-26; AST/ALT-16/22; WBC..." & @CRLF & _
"11 4/09/75 SOS-10 Total Score:\n" & @CRLF & _
"12 8/01/98 Communication with referring physician..." & @CRLF & _
"13 1/26/72 Communication with referring physician..." & @CRLF & _
"14 5/24/1990 CPT Code: 90792: With medical servic..." & @CRLF & _
"15 1/25/2011 CPT Code: 90792: With medical servic..." & @CRLF & _
"16 4/12/82 Total time of visit (in minutes):\n" & @CRLF & _
"17 1; 10/13/1976 Audit C Score, Highest/Date:\n"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")