import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d+\\/\\d+\\/\\d+)\\b";
final String string = "0 03/25/93 Total time of visit (in minutes):\\n\n"
+ "1 6/18/85 Primary Care Doctor:\\n\n"
+ "2 sshe plans to move as of 7/8/71 In-Home Servic...\n"
+ "3 7 on 9/27/75 Audit C Score Current:\\n\n"
+ "4 2/6/96 sleep studyPain Treatment Pain Level (N...\n"
+ "5 .Per 7/06/79 Movement D/O note:\\n\n"
+ "6 4, 5/18/78 Patient's thoughts about current su...\n"
+ "7 10/24/89 CPT Code: 90801 - Psychiatric Diagnos...\n"
+ "8 3/7/86 SOS-10 Total Score:\\n\n"
+ "9 (4/10/71)Score-1Audit C Score Current:\\n\n"
+ "10 (5/11/85) Crt-1.96, BUN-26; AST/ALT-16/22; WBC...\n"
+ "11 4/09/75 SOS-10 Total Score:\\n\n"
+ "12 8/01/98 Communication with referring physician...\n"
+ "13 1/26/72 Communication with referring physician...\n"
+ "14 5/24/1990 CPT Code: 90792: With medical servic...\n"
+ "15 1/25/2011 CPT Code: 90792: With medical servic...\n"
+ "16 4/12/82 Total time of visit (in minutes):\\n\n"
+ "17 1; 10/13/1976 Audit C Score, Highest/Date:\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}