#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)c\.CreateMap\<(\w+\.?\w+?)*\,\s*(?:\w*?\.?)*Address(\.\w*)?\>"
Local $sString = "c.CreateMap<ClientAddress, Address>()" & @CRLF & _
"" & @CRLF & _
"c.CreateMap<Responses.SiteAddress, Data.Address>()" & @CRLF & _
"" & @CRLF & _
"c.CreateMap<Responses.SiteAddress.abc, Data.Address.xyz>()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")