using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"c\.CreateMap\<(\w+\.?\w+?)*\,\s*(?:\w*?\.?)*Address(\.\w*)?\>";
string input = @"c.CreateMap<ClientAddress, Address>()
c.CreateMap<Responses.SiteAddress, Data.Address>()
c.CreateMap<Responses.SiteAddress.abc, Data.Address.xyz>()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}