import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "c\\.CreateMap\\<(\\w+\\.?\\w+?)*\\,\\s*(?:\\w*?\\.?)*Address(\\.\\w*)?\\>";
final String string = "c.CreateMap<ClientAddress, Address>()\n\n"
+ "c.CreateMap<Responses.SiteAddress, Data.Address>()\n\n"
+ "c.CreateMap<Responses.SiteAddress.abc, Data.Address.xyz>()";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}