$re = '/,google\b|\bgoogle,|\bgoogle\b/';
$str = 'botgoogle,googlebot,google,bot,bing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);