re = /,google\b|\bgoogle,|\bgoogle\b/
str = 'botgoogle,googlebot,google,bot,bing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end