import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=csrf=).*?(?=;)";
final String string = "{\n"
+ "\"cookie\": \"notification_requested=1; SESSID=ac2d32fafc6169a07d324328535f45dc; csrf=gxkEiaqRNxQ2gF5sFneDU9qLfIQisLSY0SBf1jCIP9HVrdcKCsQTY_pwzTudoMGi; aatr=jvSavxC; cf_clearance=faS.7Ue1wTe1CUHh8QMCNZ5JyrGBHXSnJgOrmsWlML8-1657145911-0-150; \"\n"
+ "}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}