use strict;
my $str = '{
"cookie": "notification_requested=1; SESSID=ac2d32fafc6169a07d324328535f45dc; csrf=gxkEiaqRNxQ2gF5sFneDU9qLfIQisLSY0SBf1jCIP9HVrdcKCsQTY_pwzTudoMGi; aatr=jvSavxC; cf_clearance=faS.7Ue1wTe1CUHh8QMCNZ5JyrGBHXSnJgOrmsWlML8-1657145911-0-150; "
}
';
my $regex = qr/(?<=csrf=).*?(?=;)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}