import Foundation
let pattern = #"(?<=csrf=).*?(?=;)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"cookie": "notification_requested=1; SESSID=ac2d32fafc6169a07d324328535f45dc; csrf=gxkEiaqRNxQ2gF5sFneDU9qLfIQisLSY0SBf1jCIP9HVrdcKCsQTY_pwzTudoMGi; aatr=jvSavxC; cf_clearance=faS.7Ue1wTe1CUHh8QMCNZ5JyrGBHXSnJgOrmsWlML8-1657145911-0-150; "
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)