import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[.,!?\"':”“](?:(?=.*(красной|печали).*)|(?<=.*(красной|печали).*))";
final String string = "Ах, я вспоминаю ясно, был тогда декабрь ненастный, \n"
+ ":И от! каждой в:спышки красной тень скользила на! ковер.\n"
+ "Ждал я дня из мрачной дали, тщетно ждал, чтоб книги дали\n"
+ "?Облегченье от печали по утраченной Линор, \n"
+ "По святой, что там, в Эдеме ангелы зовут Линор,\n"
+ "Безыменной здесь с тех пор.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}