const regex = /[.,!?"':”“](?:(?=.*(красной|печали).*)|(?<=.*(красной|печали).*))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[.,!?"\':”“](?:(?=.*(красной|печали).*)|(?<=.*(красной|печали).*))', 'gm')
const str = `Ах, я вспоминаю ясно, был тогда декабрь ненастный,
:И от! каждой в:спышки красной тень скользила на! ковер.
Ждал я дня из мрачной дали, тщетно ждал, чтоб книги дали
?Облегченье от печали по утраченной Линор,
По святой, что там, в Эдеме ангелы зовут Линор,
Безыменной здесь с тех пор.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);