import re
regex = re.compile(r"[.,!?\"':”“](?:(?=.*(красной|печали).*)|(?<=.*(красной|печали).*))", flags=re.MULTILINE)
test_str = ("Ах, я вспоминаю ясно, был тогда декабрь ненастный, \n"
":И от! каждой в:спышки красной тень скользила на! ковер.\n"
"Ждал я дня из мрачной дали, тщетно ждал, чтоб книги дали\n"
"?Облегченье от печали по утраченной Линор, \n"
"По святой, что там, в Эдеме ангелы зовут Линор,\n"
"Безыменной здесь с тех пор.")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)