#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:[a-z]|[A-Z]+)\K(?=[A-Z]|\d+)"
Local $sString = "SomeEquipmentHere" & @CRLF & _
"ABSBrakes" & @CRLF & _
"CDRadio" & @CRLF & _
"Valve14"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)