use strict;
my $str = 'SomeEquipmentHere
ABSBrakes
CDRadio
Valve14';
my $regex = qr/(?:[a-z]|[A-Z]+)\K(?=[A-Z]|\d+)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";