$re = '/(?:[a-z]|[A-Z]+)\K(?=[A-Z]|\d+)/m';
$str = 'SomeEquipmentHere
ABSBrakes
CDRadio
Valve14';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;