using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\- \w]+) \(([\- \w]+)\)";
string input = @"One Two (One Two Three)
One (One Two)
One (One)
OneTwo (One-two Three)
One Two
(One Two Three)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}