package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\- \w]+) \(([\- \w]+)\)`)
var str = `One Two (One Two Three)
One (One Two)
One (One)
OneTwo (One-two Three)
One Two
(One Two Three)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}