$re = '/([\- \w]+) \(([\- \w]+)\)/m';
$str = 'One Two (One Two Three)
One (One Two)
One (One)
OneTwo (One-two Three)
One Two
(One Two Three)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);