import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\da-z-]+?)(?:[-/](\\d+))?$";
final String string = "ThePixies1996\n"
+ "7ThePixies\n"
+ "The-Pixies\n"
+ "The-Pixies-1234567\n"
+ "The-Pixies/1234567";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}