re = /^([\da-z-]+?)(?:[-\/](\d+))?$/im
str = 'ThePixies1996
7ThePixies
The-Pixies
The-Pixies-1234567
The-Pixies/1234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end